Merry Christmas to all…

25 Dec

I am typing this on my shiny new Samsung laptop. It is very beautiful, very fast, every single one of the keys works every single time I hit it (which is a bit of a novelty), and it is red (because red ones go faster*). The only downside is that my very favourite game, Plants vs Zombies won’t run on the 64 bit version of Windows 7. So my wonderful Tech Support got me a copy of SimCity 4. Am I spoiled or what?

We have had a lovely day at home, just the four of us. There have been blizzards of shredded wrapping paper, lollies and chips flowing free, pitched backyard battles with the pump-action Super-Soakers that Santa brought, remote control cars running rampageous around my feet while I tried to get the pork roast into the oven, followed of course by the traditional Eating Way Too Much, and when it started raining late this afternoon,  we all piled on the couch and watched Toy Story 3 on DVD (if El Buzzo doesn’t make you hoot with laughter, then nothing ever will!).

Tomorrow, we head off to the in-laws’ for a few days with the family (aunties and uncles and cousins, oh my!), then home again in time for New Years Eve.

I hope you have had a bright and beautiful holiday, however you choose to spend it, and if you are travelling, go safely and come home rested and relaxed.

____

*and because they didn’t have a purple one.

Advertisements

4 Responses to “Merry Christmas to all…”

  1. 2paw December 25, 2010 at 9:24 pm #

    What a fabulous gift!! I am sad for you there wasn’t a purple one, but red ones do go faster!! Merry Christmas!!

  2. amy December 26, 2010 at 6:23 am #

    Merry Christmas! We’re also having a day at home, just the five of us, except we watched Star Wars: The Clone Wars on DVD (okay, I napped a bit) and built a marble run rather than playing with Super Soakers (a bit chilly for that). Safe travels and enjoy your visiting!!

  3. Leonie January 1, 2011 at 1:34 pm #

    Yay for shiny new red laptops, sorry about the purple, but now we match! Oh except mine is a Dell. With the 64 bit thing: Right click on program icon, then select “properties” then select “compatibility” where you can click “run in compatibility mode for Windows XP service pack 3” or something like that. Had to do it with at least one program when I upgraded to Windows 7. Fixed the problem. Hope you get Plants v. Zombies back 🙂

    • kissmyfrog January 1, 2011 at 5:42 pm #

      Thanks for the advice; already tried it and it didn’t work. So the New Hotness is devoid of zombies. 😦 At least until they upgrade the game, which they’ll have to do sooner or later. Right? Meantime, the rest of the ‘putey is a veritable Cave of Very Fast Wonders! Yay!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: